Palo Alto Confirms Critical 9.2-Severity Flaw in PAN-OS Firewalls, Ships Workarounds Ahead of Patches
Read Time:3 Minute, 49 Second
Palo Alto Networks has published an advisory confirming that a critical vulnerability in
Altro...
Read Time:3 Minute, 49 Second
Palo Alto Networks has published an advisory confirming that a critical vulnerability in
Altro...Read Time:3 Minute, 49 Second
Palo Alto Networks has published an advisory confirming that a critical vulnerability in the open-source Brotli compression library reaches into some of its PAN-OS firewall deployments, along with a companion tool used in its Prisma Cloud offering. The flaw, tracked as CVE-2026-111497, carries a severity score of 9.2 out of 10 — putting it firmly in critical territory, even though Palo Alto itself has only assigned the issue moderate response urgency internally.
What the Bug Actually DoesThe root cause sits inside decode.c, part of Google’s Brotli decompression engine. A specially crafted compressed data stream can trigger what’s known as an out-of-bounds write — essentially tricking the decoder into writing data past the boundary of the memory buffer it’s supposed to stay inside. Depending on how that memory gets overwritten, the consequences can range from corrupting unrelated data and crashing a service, to exposing sensitive information, to a worst-case scenario of unauthenticated remote code execution.
Google has already shipped fixed versions of the underlying Brotli library — 1.0.10, 1.1.1, and 1.2.1, depending on the release branch — but because Brotli is embedded inside a wide range of downstream software, each vendor that bundled a vulnerable copy has to ship its own fix separately. This isn’t the first product caught up in the fallout: Node.js previously issued security updates addressing the same decoder flaw, underscoring how a single open-source dependency bug can ripple across unrelated products for weeks.
Who’s Actually ExposedFor PAN-OS customers, exposure isn’t universal — it depends entirely on configuration. A firewall is only at risk if both of the following are true:
Brotli traffic inspection is enabled on the dataplane (the component that actually processes network traffic)
TLS/SSL decryption is also enabled, since that’s what exposes the compressed content to inspection in the first place
Critically, Brotli inspection ships disabled by default and isn’t even supported on PAN-OS versions before 11.2.4. That means PAN-OS 11.1 and 10.2 branches are unaffected entirely, as are Panorama and M-Series management appliances. The firewall’s management web interface and API are also outside the blast radius — this is strictly a dataplane traffic-inspection issue.
Administrators running PAN-OS 11.2.4 or later can check their exposure directly with the command show system setting brotli. A result of Enabled: yes means Brotli inspection is active, though TLS/SSL decryption still needs to be confirmed separately to fully assess risk.
Workarounds Available Now, Patches Coming LaterBecause official hotfixes won’t be available until October 27–30 at the earliest, Palo Alto is urging customers to mitigate immediately rather than wait. The recommended workaround depends on the PAN-OS version:
Via CLI: run set system setting brotli-encoding disable, then confirm with show system setting brotli that it now reports Enabled: no
On PAN-OS 12.1.2 and later: navigate to Device > Setup > Content-ID, clear the “Allow Brotli Encoding” option, and commit the change
Customers subscribed to Threat Prevention get an additional, partial layer of coverage through Threat ID 97686, included in Applications and Threats content version 9165 or later — but Palo Alto is explicit that this signature-based protection is conditional on specific traffic routing, decryption, and policy settings, and should not be treated as a substitute for disabling the feature outright.
The planned hotfix builds span a wide swath of the PAN-OS release tree, including 12.2.4-h1, 12.1.4-h13, 12.1.10-h3, 11.2.4-h23, 11.2.10-h17, and 11.2.16-h1, among others. Palo Alto flags one easy-to-miss detail: 11.2.10-h16 only resolves a separate, unrelated PHP issue — it’s 11.2.10-h17 that adds the Brotli fix, so teams tracking build numbers should double-check they’re grabbing the right one.
Prisma Cloud Users Also AffectedOutside the firewall line, Palo Alto’s Prisma Cloud Application Security Transporter Client also ships a vulnerable Brotli copy and needs to be upgraded to version 0.2.9 or later. The company says several of its own cloud services — including ADEM, Cloud Identity Engine, Hub, and Prisma AIRS Gateway — have already been remediated on the backend, requiring no customer action.
With no confirmed exploitation in the wild but a critical severity score and a multi-day gap before official patches land, the practical move for affected organizations is straightforward: disable Brotli inspection now, verify the setting took effect, and schedule the hotfix once it’s confirmed available for the specific build in use.